[GRLUG] fstab query

Eric Beversluis ebever at researchintegration.org
Tue Nov 12 12:57:08 EST 2013

We are trying to insert a line into fstab on a ClearOS (based on CentOS)
server to mount an ioSafe on reboot. Something doesn't seem to be
working right. The first time we rebooted after inserting the line (see
below) into fstab, it crashed. We removed the line from fstab and
manually mounted the ioSafe. Another time we tried again; this time it
seemed to boot ok but the ioSafe did not mount.

Are we going about this right?
We formated the ioSafe this way (retaining the GPT partition table):
Num Start  End    Size   File sys Name                         Flags
1   17.4kB 134MB  134MB           Microsoft reserved partition msftres
2   135MB  4001GB 4001GB ext4     Basic data partition

(Research seemed to suggest it best to leave the MS reserved partition.)

The fstab line we entered was this:
UUID=dd06173e-9fb2-47f8-8841-5ed96e4d4ee4 /mnt/ioSafe ext4
defaults,nofail 0 0

(The first time we set the <pass> value to 2.)

It has been suggested that the reason this fstab entry doesn't work is
that the first partition does not have the ext4 file system.

--Does any know, is that really the case--that it won't mount partition
2 (using the UUID of partition 2) because partition one is a different
file type? It mounts partition 2 fine manually from the 'mount' command
(using /dev/sdc2; I haven't tried using the UUID with mount) .

--if so, can I just delete the first partition and leave blank space? I
would not want to re-format the whole drive, since we already have
backup data on it.


More information about the grlug mailing list